Author Topic: lin vst server error  (Read 264 times)

0 Members and 1 Guest are viewing this topic.

Offline chinface

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
  • AVLinux User
lin vst server error
« on: March 15, 2019, 07:32:14 AM »
scanning for vst plugins
/usr/local/lib/vst give this error:
under reaper (Linux version) and ardour both give a lin vst server error (attached screen cap)

none of the converted vsts show up (these are all the ones that come pre installed btw)

any idea what might be causing this?

Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 3125
  • Karma: +47/-0
  • A/V 'Nixer
    • www.bandshed.net
Re: lin vst server error
« Reply #1 on: March 15, 2019, 04:13:02 PM »
Hi,

Hmmm, OK..

Even though the linvstconvertree utility was missed in a packaging error the last AV Linux LiveISO was tested and had LinVST working when it was released, did it work for you before you updated to the new package?

Did you install the updated LinVST package from the other thread? If so did you run linvstconvert and linvstconverttree again with the new package installed to create new '.so' files. It has to be run in a Root Terminal..

Answer those questions and we'll see where we're at.

Offline chinface

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
  • AVLinux User
Re: lin vst server error
« Reply #2 on: March 16, 2019, 01:07:19 AM »
I had done a fresh install, and installed the linvst deb package first before trying, and that's when it gave me the error message

I have just done a fresh reinstall now and tried it without installing the linvstconverttree deb package.

this time, I loaded ardour and while scanning for vsts, it gave me the error (while downloading wine mono) - however this time the plugins showed up, and when scanning in reaper, it all went fine

so  I guess the issue is the linvstconverttree package somehow?


Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 3125
  • Karma: +47/-0
  • A/V 'Nixer
    • www.bandshed.net
Re: lin vst server error
« Reply #3 on: March 16, 2019, 09:51:13 AM »
Hi,

The package I provided does work here, so it on it's own is most likely not the problem, in the meantime there has been another upgrade to linvst 2.4.2 which I am testing now..

The problem can be that wine doesn't run it's initial setup and config until it is called by the system for the first time... If the first time is during an initial LinVST plugin scan then there is too much going on at once, wine is trying to write it's config while LinVST's scanner is running, then it times out and fails, if the scan fails then the plugins are not shown as available..

On a side note if you are just using wine in AV Linux to run VST Plugins and WineASIO there is no reason at all to install the mono and gecko modules, especially if wine launches for the first time during a LinVST plugin scan.

I can understand that you may want to just leave things alone if they are working now, if you don't want to upgrade at this point it is possible to get the linvstconverttree application and run it by itself without upgrading if you want..

Offline chinface

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
  • AVLinux User
Re: lin vst server error
« Reply #4 on: March 17, 2019, 06:11:00 PM »
awesome thanks for the info, makes sense.


I'm just in the process of setting my computer up, and haven't actually done any recording etc so far, so if there was an update to linvst I might as well try it