Author Topic: slow boot: Begin: running /scripts/local-block...done.  (Read 1375 times)

0 Members and 1 Guest are viewing this topic.

Offline conjunctivitis

  • Hero Member
  • *****
  • Posts: 170
  • Karma: +2/-0
slow boot: Begin: running /scripts/local-block...done.
« on: April 18, 2018, 03:27:26 AM »
hi everyone,

i just installed avl2018 :-)

boot is slow, at a certain point in the boot sequence it starts repeating the line

Begin: running /scripts/local-block...done.

about once a second until it fills the screen.  then it dumps me to a console login (functional) for about 10 seconds before finally showing the gui login screen.

any ideas?

i'm using a dell xps 13 from 2015.

thanks in advance.

Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 3099
  • Karma: +45/-0
  • A/V 'Nixer
    • www.bandshed.net
Re: slow boot: Begin: running /scripts/local-block...done.
« Reply #1 on: April 18, 2018, 10:26:32 AM »
Hi,

Is this a UEFI install? I've only seen this on UEFI (in Virtualbox) and it seems to be harmless, it's an annoyance but once logged in the system functions as normal.

Offline conjunctivitis

  • Hero Member
  • *****
  • Posts: 170
  • Karma: +2/-0
Re: slow boot: Begin: running /scripts/local-block...done.
« Reply #2 on: April 18, 2018, 03:05:19 PM »
hi glen,

i'm actually not sure :-p  how can i check?

it's a pretty recent computer, but i think i enabled legacy mode in the bios prior to installing.  in any case you're right, it is simply a minor annoyance, just wanted to see if there was a way to get rid of it or accelerate the boot.

the main thing holding me back right now though is the networking problem in my other post.

dan

Offline rockhopper

  • Hero Member
  • *****
  • Posts: 100
  • Karma: +2/-0
    • RockHopper
Re: slow boot: Begin: running /scripts/local-block...done.
« Reply #3 on: April 27, 2018, 10:40:13 AM »
Hi conjunctivitis,

If it's a recent computer it's very likely to be a UEFI BIOS. I've also got a fairly recent PC with a UEFI BIOS and had the same issue with the slow boot and repeated "Begin: running /scripts/local-block...done." To fix this, I replaced the packages grub-efi and grub-efi-64 with grub-pc and grub-pc-bin using Synaptic. The console login is still displayed for a while before the graphical login appears, so this may be a separate issue.

Offline rockhopper

  • Hero Member
  • *****
  • Posts: 100
  • Karma: +2/-0
    • RockHopper
Re: slow boot: Begin: running /scripts/local-block...done.
« Reply #4 on: April 27, 2018, 11:06:32 AM »
Just discovered how to fix the long wait at the console login! Simply uninstall the Virtualbox guest additions by opening a root terminal and entering:

Code: [Select]
cd /opt/VBoxGuestAdditions-5.*
./uninstall.sh

Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 3099
  • Karma: +45/-0
  • A/V 'Nixer
    • www.bandshed.net
Re: slow boot: Begin: running /scripts/local-block...done.
« Reply #5 on: April 27, 2018, 12:16:43 PM »
Just discovered how to fix the long wait at the console login! Simply uninstall the Virtualbox guest additions by opening a root terminal and entering:

Code: [Select]
cd /opt/VBoxGuestAdditions-5.*
./uninstall.sh

Thanks VERY much for sharing that!!

Offline sam0th

  • Full Member
  • ***
  • Posts: 27
  • Karma: +1/-0
    • Nacht-Soundcloud
Re: slow boot: Begin: running /scripts/local-block...done.
« Reply #6 on: May 03, 2018, 03:30:22 PM »
hi,

replacing the pakages didnt solve it for me, maybe because i am using the grub from another installation on another harddisk to start avlinux and this grub i wont touch. but there is another solution for scripts, found on youtube, like to share:

https://www.youtube.com/watch?v=w-XfOR4LDi0

this works for me and seems to be a clean way.


Offline rockhopper

  • Hero Member
  • *****
  • Posts: 100
  • Karma: +2/-0
    • RockHopper
Re: slow boot: Begin: running /scripts/local-block...done.
« Reply #7 on: May 04, 2018, 04:54:04 AM »
Hi sam0th,

That's interesting. So maybe grub-efi wasn't the problem after all. I remember that after installing grub-pc, the boot process got stuck at a blank screen for a long time before printing "Gave up waiting for suspend/resume device". I managed to fix this by reformating the swap partition and entering it's new UUID into the suspend/resume config. From what you say, reformatting the swap may not be necessary either.

So according to the youtube video:
  • open a root terminal and run "blkid"
  • paste the UUID of the swap partition into /etc/initramfs-tools/conf.d/resume where it says "RESUME=UUID="
  • finally, run "update-initramfs -u"

If you want to reformat your swap partition do as follows:
  • open gparted, right-click the swap partition and select "swap off"
  • reformat the swap partition
  • open a root terminal and run "mkswap /dev/sda8" (change sda8 to whatever drive/partition your swap is on)
  • this outputs a new UUID for the swap which needs to be pasted into both /etc/fstab and /etc/initramfs-tools/conf.d/resume
  • finally, run "update-initramfs -u"

source: https://superuser.com/questions/1204627/deleted-a-partition-now-getting-gave-up-waiting-for-suspend-resume-device-mes#1204634

Offline sam0th

  • Full Member
  • ***
  • Posts: 27
  • Karma: +1/-0
    • Nacht-Soundcloud
Re: slow boot: Begin: running /scripts/local-block...done.
« Reply #8 on: May 04, 2018, 11:17:43 AM »
so i guess the installation process (remastersys?) uses during live session another UUID for an existing swap than the real UUID, which leads to the boot error because it wants to load an nonexisting device.. ?
just an idea. i hate coding so i wont look for it.

Offline korakios

  • Hero Member
  • *****
  • Posts: 213
  • Karma: +9/-1
Re: slow boot: Begin: running /scripts/local-block...done.
« Reply #9 on: May 07, 2018, 04:26:28 PM »
I didn't have a swap partition ,but still got the same message and the boot was very sloowww.
I added the flag
Code: [Select]
noresumeon boot options and solved. (I don't know if it messes with hibernation)