Author Topic: New readable/writeable clients Sink-01 and Source-01 out of the blue.  (Read 326 times)

0 Members and 1 Guest are viewing this topic.

Offline hawran.diskuse

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
  • Remastersys and AVLinux User
Hi,
I've started qjackctl up today and I've noticed new readable/writable clients PulseAudio JACK Sink-01 and PulseAudio JACK Source-01 aside from the original ones PulseAudio JACK Sink and PulseAudio JACK Source.
What has happened?

I have not upgraded/installed/changed anything. Neither an application nor a hardware.
(Except for some qjackctl's settings as I've been trying to solve problems with a midi controller.)

Offline nik gnomic

  • Jr. Member
  • **
  • Posts: 18
  • Karma: +0/-0
  • AVLinux User
Re: New readable/writeable clients Sink-01 and Source-01 out of the blue.
« Reply #1 on: March 30, 2018, 08:12:12 AM »
Have you recently turned on D-Bus support in QjackCtl?

D-Bus interacts with Pulseaudio using module-jackdbus-detect and will automatically create Pulseaudio JACK sink/source connections when JACK is started.

If commands are used to load Pulseaudio connections manually:
pactl load-module module-jack-sink
pactl load-module module-jack-sink

Pulseaudio will add another sink/source connection pair
Use commands again you would get Pulseaudio JACK Sink 02 and Pulseaudio JACK Source 02

Remove any commands you have added in QjackCtl to add Pulseaudio sink/source, then you will get one sink/source pair loaded automatically

Alternatively, You could disable the option load-module module-jackdbus-detect in Pulseaudio configuration file (default.pa) and keep the QjackCtl commands

Offline hawran.diskuse

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
  • Remastersys and AVLinux User
Re: New readable/writeable clients Sink-01 and Source-01 out of the blue.
« Reply #2 on: April 02, 2018, 03:42:44 PM »
Have you recently turned on D-Bus support in QjackCtl?
D-Bus interacts with Pulseaudio using module-jackdbus-detect and will automatically create Pulseaudio JACK sink/source connections when JACK is started.
Yes, I've done it when I was trying to solve a problem with my MIDI controller.
As I wrote there, documentation is rather unclear and inhomogeneous: one peace says "to check it" and the other "to uncheck it".

If commands are used to load Pulseaudio connections manually:
pactl load-module module-jack-sink
pactl load-module module-jack-sink

Pulseaudio will add another sink/source connection pair
Use commands again you would get Pulseaudio JACK Sink 02 and Pulseaudio JACK Source 02
I presume there should be
pactl load-module module-jack-source
on the second line.
Nevertheless, thank you for the explanation.

Remove any commands you have added in QjackCtl to add Pulseaudio sink/source, then you will get one sink/source pair loaded automatically
Alternatively, You could disable the option load-module module-jackdbus-detect in Pulseaudio configuration file (default.pa) and keep the QjackCtl commands
Well, I've got the default settings as described here.

Thank you.

Offline nik gnomic

  • Jr. Member
  • **
  • Posts: 18
  • Karma: +0/-0
  • AVLinux User
Re: New readable/writeable clients Sink-01 and Source-01 out of the blue.
« Reply #3 on: April 08, 2018, 11:21:47 AM »
I presume there should be
pactl load-module module-jack-source
on the second line.

Apologies, it was typo on second line. you presumed correct

pajackconnect script loads sink and source in similar way, but with pacmd rather than pactl

Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 3069
  • Karma: +39/-0
  • A/V 'Nixer
    • www.bandshed.net
Re: New readable/writeable clients Sink-01 and Source-01 out of the blue.
« Reply #4 on: April 08, 2018, 03:10:24 PM »
Hi,

You shouldn't need to edit any system files, just turn off any d-bus options in Qjackctl..

Qjackctl-->Setup-->Misc tab-->Uncheck anything pertaining to D-bus


Offline hawran.diskuse

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
  • Remastersys and AVLinux User
Re: New readable/writeable clients Sink-01 and Source-01 out of the blue.
« Reply #5 on: April 15, 2018, 02:14:04 PM »
Hi,

You shouldn't need to edit any system files, just turn off any d-bus options in Qjackctl..

Qjackctl-->Setup-->Misc tab-->Uncheck anything pertaining to D-bus

OK, I think I got the point.
Thank you!