Author Topic: Manually Updating Flash Player for Firefox  (Read 2139 times)

0 Members and 1 Guest are viewing this topic.

Offline rockhopper

  • Sr. Member
  • ****
  • Posts: 86
  • Karma: +2/-0
    • RockHopper
Manually Updating Flash Player for Firefox
« on: August 20, 2017, 10:48:38 AM »
AVLinux comes with the package flashplugin-nonfree pre-installed. When this package is updated to a newer version (or when update-flashplugin-nonfree --install is run in a terminal) the latest version of the flash plugin is downloaded and installed. Unfortunately the package appears to be no longer maintained, giving the following error message when run: "ERROR: wget failed to download http://people.debian.org/~bartm/flashplugin-nonfree/..."

To update Flash Player for Firefox manually:
  • get the latest version in .tar.gz format from https://get.adobe.com/flashplayer/
  • unzip and extract the contents: tar -zxf flash_player*.tar.gz
  • as root, copy the flashplayer.so library to the appropriate directory: cp libflashplayer.so /usr/lib/flashplugin-nonfree/
  • as root, give the file the correct permissions: chmod 644 /usr/lib/flashplugin-nonfree/libflashplayer.so
  • as root, set the file's owner to root: chown root:root /usr/lib/flashplugin-nonfree/libflashplayer.so
Source: https://wiki.debian.org/FlashPlayer/#Manual_update